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ОБЩИЕ ТРЕБОВАНИЯ 
 

К выполнению лабораторных работ допускаются студенты после 
ознакомления с правилами техники безопасности при работе на ПЭВМ.   

Работы выполняются в часы, предусмотренные расписанием за-
нятий. В остальных случаях необходимо согласовать время отработки 
пропущенных лабораторных занятий с преподавателем. 

 
1. Инструкция по технике безопасности 

 
К работе допускаются студенты, прошедшие инструктаж по тех-

нике безопасности на рабочем месте, о чем в журнале делается соот-
ветствующая запись. 

В процессе лабораторных занятий необходимо строго соблюдать  
правила техники безопасности. Несоблюдение правил может привести 
к поражению нарушителя или его напарников электрическим током с 
последствиями, опасными для жизни или здоровья. 

Чтобы обезопасить себя и своих товарищей от действия электри-
ческого тока, необходимо выполнять следующие правила: 

- все электрические напряжения свыше 24 В следует считать 
опасными и поэтому принимать все меры предосторожности; 

- перед включением приборов необходимо ознакомиться с инст-
рукцией по их эксплуатации; 

- во время выполнения работы на рабочем месте (в рабочем по-
мещении) должно находиться не менее двух человек; 

- запрещается самостоятельно снимать защитные корпуса и эк-
раны с оборудования; 

- нельзя оставлять оборудование включенным без надзора; 
- включать и выключать оборудование можно только штатными 

выключателями; 
- включение питания от силового щита выполняется только пре-

подавателем или лаборантом;  
- после выполнения программы лабораторной работы необходи-

мо сообщить об этом преподавателю, и после получения соответст-
вующего разрешения выключить установку и привести ее в исходное 
состояние. 

Если, несмотря на выполнение основных правил работы с элек-
троустановками, произошел несчастный случай, необходимо принять 
экстренные меры по отключению установки от электрической сети. 
Лучше всего это сделать с помощью выключателя на входном силовом 
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электрическом щите. Следует поставить в известность о происшествии 
преподавателя или лаборанта и под их руководством приступить к лик-
видации последствий несчастного случая. 

Эффективность спасения пострадавшего от электрического тока 
зависит от того, насколько быстро он будет освобожден от действия 
тока, а также от того, насколько быстро и квалифицированно оказана 
первая помощь. Следует помнить, что для оказания действенной по-
мощи имеется всего 5-7 минут. 

 
2. Подготовка к работе 

 
Для успешного выполнения лабораторной работы студенту не-

обходимо: 
- ознакомиться с методическими указаниями к лабораторной ра-

боте; 
- изучить используемый в методических указаниях раздел теоре-

тического курса по рекомендованному учебнику или конспекту лекций; 
- продумать методику выполнения измерений и исследований, 

предусмотренных методическими указаниями к лабораторной работе; 
- выполнить рекомендованные в методических указаниях расче-

ты; 
- подготовить таблицы для записи результатов экспериментов.  

 
 

КРАТКИЕ СВЕДЕНИЯ О СРЕДЕ MICROWAVE OFFICЕ 
 

1.     Основные        особенности       среды       проектирования  
Microwave Office 

 
В 1998 году компания Applied Wave Research выпустила на ми-

ровой рынок САПР СВЧ устройств мощное интегрированное решение 
Microwave Office® (MO). 

Система MO предлагает средства электромагнитного анализа 
планарных структур, разработки и моделирования линейных и нели-
нейных схем, редактирования топологии и объемного электромагнит-
ного анализа. Вычислительный модуль системы работает как в частот-
ной, так и временной областях и выполняет следующие виды анализа 
линейных и нелинейных схем: 

- одночастотный и многочастотный методы гармонического ба-
ланса для анализа нелинейных схем;  
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- анализ на основе рядов Вольтерра;  
- конверсионно-матричный анализ;  
- высокоскоростной метод линейного анализа и анализа шумов;  
- анализ переходных процессов. 
Таким образом, программа представляет полный набор инстру-

ментов, обеспечивающий сквозной цикл проектирования с использова-
нием ключевых технологий: моделирования линейных и нелинейных 
схем, электромагнитного моделирования, взаимной верификации схе-
мы и топологии, статистического анализа, использования параметризо-
ванных топологических элементов. MO обеспечивает законченное ре-
шение для проектирования обычных схем, монолитных СВЧ инте-
гральных схем (MMIC), корпусов, одно- и многокристалльных модулей 
и печатных плат. Средства электромагнитного моделирования позво-
ляют выполнять анализ антенн в дальней зоне. МО обладает интегри-
рованной системой ввода схем с поддержкой форматов Spice и 
MMICAD. 

Последней версией продукта является MO 2008, который вклю-
чает ряд ключевых усовершенствований, направленных на ускорение 
процесса проектирования и обеспечение расширенных возможностей 
по  моделированию. 

Требования к вычислительным ресурсам компьютера зависят от 
категории решаемых задач. Установка программы на платформе PC-
Windows возможна при наличии оперативной памяти объемом 256 МВ, 
но для расчета сложных схем может потребоваться до 4 GB. На цен-
тральный процессор предъявляются требования не ниже, чем Pentium-
III или эквивалентный ему. 

 
2. Запуск программы и основные элементы управления 
 
После установки программы на рабочем столе Windows® поя-

вится пиктограмма фирмы AWR. Запуск MO выполняется двойным 
нажатием левой кнопкой мыши (НЛКМ) на пиктограмме, либо НЛКМ 
по кнопке Пуск операционной системы и выбором строки программы 
AWR Suite. После запуска открывается главное окно среды AWR Design 
Environment (AWR), где помещены инструменты проектирования ра-
диоэлектронных средств, предоставляемые этой средой проектирова-
ния. Вид окна AWR показан на рис. 1.  

MO содержат Visual System Simulator (VSS), интегрированный в 
среду проектирования AWR. Он предназначен для моделирования сис-
темных свойств радиоэлектронных цепей. VSS можно запустить как 
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отдельную программу, либо вместе со всей программой MO. На виде 
главного окна среды проектирования AWR это не отразится. Проявятся 
изменения в главном меню и на панели инструментов. Использование 
VSS позволяет моделировать радиоканалы, шумы в них, находить ве-
роятности ошибок и оценивать работу проектируемых радиоэлектрон-
ных устройств в составе тех или иных систем.  

 

 
Рис. 1. Главное окно 

 
Главное окно среды проектирования AWR по вертикали разде-

лено на две части. В левой части содержатся средства управления. Пра-
вую сторону окна AWR могут занимать окна, где представлены схемы, 
блок-схемы, графики и другие окна. По верхнему краю окна AWR рас-
положены обычные объекты системы Windows. 

Главное меню и панель инструментов MO показаны на рис. 2 
при активности окон основных объектов проектирования.  

Меню и панель инструментов изменяют свой вид, когда активи-
зируется другое окно или объект. Главное меню содержит команды,  
необходимые для работы с проектом. Команды меню вызываются ме-
тодом операционной системы Windows. Если в открытом окне выделен 
какой-то объект, то нажатием правой клавиши мыши (НПКМ) вызыва-
ется контекстное меню этого объекта. В нем представлены команды 
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управления объектом и в том числе команда вызова окна диалога, в 
котором производят настройки параметров этого объекта. 
 

 
а 

 
б 

Рис. 2. Главное меню и панель инструментов 
а – для активного окна схемы цепей, б – для активного окна электро-

магнитной структуры 
 

Менеджер AWR расположен в левой вертикальной полосе глав-
ного окна программы. Средства управления проектом распределены по 
четырем группам, и каждая группа помещена на отдельную вкладку. 
Каждая из четырех вкладок в менеджере AWR имеет свое собственное 
имя: Project (Proj), Elements (Elem), Variables (Var), Layout. Переход на 
вкладку выполняется НЛКМ на ярлычке, расположенном на нижнем 
краю вкладок.  

Вкладка Project содержит узлы графа или ветви дерева иерархии 
инструментов управления проектом и объекты, которые могут быть 
использованы в данном проекте или уже созданы в нем.  

Верхний узел отдан текстовому редактору Design Notes. В нем 
хранятся заметки разработчика.  

Project Options - это узел параметров проекта, из которого осу-
ществляются все глобальные настройки.  

Global Definition - специальный редактор глобальных определе-
ний. Он позволяет вводить в проект глобальные переменные и затем их 
использовать в качестве синхронно изменяемых значений для многих 
параметров элементов схем, блоков диаграмм и других.  

Data Files - папка для хранения импортируемых файлов пара-
метров элементов. Импортированные файлы данных должны иметь 
общепринятый формат представления параметров СВЧ цепей.  

System Diagrams - многофункциональный узел для хранения и 
управления. Структуры систем представляют в проекте уровень или 
аспект системных свойств проектируемых радиоэлектронных уст-
ройств. Из этого узла вызывается окно диалога для настройки режимов 
моделирования системных свойств. Здесь же хранятся все структуры 
систем, созданные в проекте или присоединенные.  
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Circuit Schematic - многофункциональный узел, где можно со-
хранять и управлять всеми схемами цепей, доступными проекту.  

EM Structures - многофункциональный узел, похожий на два пре-
дыдущих, здесь находятся и отсюда управляются электромагнитные 
структуры.  

Output Equations - узел хранения и управления, в котором опре-
деляют выходные данные типа вычисляемых переменных, сохраняе-
мых после сеанса работы в среде проектирования AWR.  

Данные, получаемые во время сеанса работы в среде проектиро-
вания AWR, имеют формат графиков. Управление ими осуществляется 
в узле Graphs.  

Optimizer Goals – в этом узле создаются критерии или цели оп-
тимизации. Настройка режимов оптимизации производится в специ-
альном окне диалога, вызываемого из этого узла.  

Yield Goals – в данном узле создают и хранят цели статистиче-
ского анализа. Отсюда вызывают окно диалога для управления стати-
стическим анализом цепи или системы.  

Output Files  - узел определения содержания и хранения выход-
ных данных в специальных форматах.  

Wizards - программные средства для синтеза фильтров, анализа 
переменных нагрузок и др.  

Scripting - инструменты создания сценариев. Сценариями можно 
определить действия проектировщика. 

Вкладка Elements отображает элементы, из которых можно со-
ставлять схемы цепей и структуры систем. Эту часть менеджера среды 
проектирования AWR называют менеджером элементов. Верхняя часть 
вкладки содержит дерево всех библиотек элементов, доступных для 
установки их в схемы и блок-схемы. На нижней части вкладки отобра-
жают элементы, входящие в состав библиотеки, выделенной на верхней 
части менеджера элементов. Библиотеки объединены в две большие 
группы: Circuit Elements - элементы цепей и System Blocks - блоки сис-
тем. Блоки систем не используют в схемах цепей, как и наоборот, эле-
менты цепей не используют в системах. Однако схемы и подсхемы це-
пей можно установить в блоки систем, пользуясь библиотекой блоков 
систем.  

Элементы цепей сгруппированы по следующим классам: копла-
нарные элементы, общие элементы, переходные соединения, линейные 
устройства, дискретные элементы, измерительные приборы, микропо-
лосковые (полосковые) элементы, нелинейные устройства, порты, ис-
точники тока и напряжения, металлодиэлектрические подложки, линии 
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передачи. Кроме этого, в проекте возможно использование: библиотек 
моделей в формате Spice, доступных подсхем, библиотек моделей в 
формате Touchstone, библиотеки элементов в формате XML.  

Блоки систем образуют другую совокупность классов:  каналы, 
кодирование, преобразователи, внешние приложения, фильтры, мате-
матические блоки, измерительные приборы, блоки модуляции, порты, 
радиочастотные блоки, сигнальные преобразования, источники сигна-
лов и подсистемы. 

Параметры элементов схем и блоков систем называют «пере-
менными». Вкладка Variables является менеджером переменных. Он 
обеспечивает просмотр значений переменных, редактирование их зна-
чений или управление их состоянием. Данные переменные могут иметь 
три состояния: 

- T - изменение значения переменной в реальном времени (тю-
нер); 

- O - оптимизация переменной по заданному функционалу цели; 
- C - режим ограничения диапазона изменения переменной. 
В верхней части менеджера переменных помещена часть дерева 

проекта, в которой можно видеть схемы цепей, структуру систем, лис-
ты соединений, электромагнитные структуры и внешние файлы, дос-
тупные из проекта. Нижнюю часть вкладки занимает таблица перемен-
ных. Ее строки отображают список переменных модуля, который выде-
лен в верхней части. Три кнопки слева строки таблицы управляют со-
стоянием переменной: возможности тюнера, оптимизации и ограниче-
ния диапазона текущих значений. 

Вкладка Layout - это менеджер макета. Он отображает расслое-
ние макета и содержит средства организации информации о конструк-
ции проекта и управления библиотеками ячеек макета. Верхнюю часть 
вкладки менеджера макета занимает узел Layer Setup. В нижней части 
приведена таблица управления слоями макета. Первый слева столбец 
содержит кнопки активации слоя. Органом управления видимостью 
слоя служит кнопка с видом лампы накаливания. Если она «светится» 
желтым светом, то слой макета виден в окне макета. Выключение ви-
димости слоя дает возможность лучше рассмотреть детали изображе-
ния. Включение видимости позволяет рассмотреть совмещение границ 
или наложение проводников. 
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3. Создание, открытие и сохранение проектов электрических 
схем 

 

В МО допускаются длинные имена файлов и символы кирилли-
цы в имени файла. Тем не менее, лучше использовать латиницу. МО 
одновременно может работать только с одним проектом. В одном про-
екте можно создать несколько схем различных цепей, несколько раз-
личных систем и несколько электромагнитных структур. Схемы цепей 
и систем можно строить иерархически, в том числе со многими уров-
нями вложенных подсхем. Что касается электромагнитных структур 
(EM-структуры), то допускаются только одноуровневые, то есть вло-
женные в них подструктуры недопустимы. В пакете программ AWR 
используются пять типов файлов. Они зарегистрированы в операцион-
ной системе Windows. Эти типы файлов отмечены специальными знач-
ками и имеют определенное расширение имени: 

- файлы проектов имеют расширение имени -.emp; 
- файлы структур систем имеют расширение имени -.sys; 
- файлы EM структур имеют расширение имени -.em; 
- файлы схем цепей имеют расширение имени -.sch; 
- файлы списков соединений с расширением имени -.net. 
При первоначальной загрузке программы AWR по умолчанию 

открывается проект, который имеет имя Untitled Project.  
Для создания нового проекта выбираем в меню: File>New 

Project. Новому проекту присваиваем имя: File>Save Project As. Новое 
имя отражается в строке заголовка. Чтобы открыть проект, выполняем: 
File>Open Project. Для сохранения текущего проекта: File>Save Project 
As. 
 

Лабораторная работа № 1 
 

АНАЛИЗ И ОПТИМИЗАЦИЯ ЛИНЕЙНЫХ ВЧ УСТРОЙСТВ 
 

ЦЕЛЬ РАБОТЫ: знакомство с пакетом Microwave Office, ана-
лиз и оптимизация параметров линейных ВЧ устройств. 

 

КРАТКИЕ СВЕДЕНИЯ 
 

1. Построение и анализ пассивных цепей  
 

Рассмотрим построение и анализ пассивных цепей на примере 
фильтра нижних частот (ФНЧ) на элементах со сосредоточенными па-
раметрами. 
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ФНЧ, представленный на рис. 3, в МО имеет следующий вид 
(рис. 4). 

 
Рис. 3. Анализируемый фильтр 

 

 
Рис. 4. Анализируемый фильтр в МО 

 
Алгоритм создания и анализа схем в МО на данном примере вы-

глядит следующим образом. 
1.1. Создаем проект с определенным именем: File>New Project. 
1.2. Определяем единицы измерения в проекте:  
- выбираем Options>Project Options;  
- выбираем вкладку Global Units;  
- устанавливаем единицы измерения в появившемся диалоговом 

окне (рис. 5). 
1.3. Создаем схему:  
- выбираем команду Project>Add Schematics>New Schematics; 
- называем схему определенным именем, на рабочем поле поя-

вится окно схемы и в папке Circuits Schematics в дереве проекта поя-
вится папка новой схемы. 

1.4. Размещаем элементы в схеме: 
-  НЛКМ Elem, расположенную слева в нижней части экранного 

окна, и вызываем дерево элементов; 
- находим в дереве элементов Lumped Element и НЛКМ на значке 

+; 
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Рис. 5. Диалоговое окно установки единиц измерения 

 
- НЛКМ Inductor в Lumped Element, чтобы вызвать модели суще-

ствующих индуктивностей в окне, расположенном под деревом эле-
ментов; 

- НЛКМ на модели индуктивности Ind и, не отпуская клавишу, 
перетаскиваем индуктивность на поле схемы; 

- размещаем элемент в нужном месте и НЛКМ еще раз, подтвер-
ждая установку в этом месте. Для быстрого соединения элементов не-
обходимо в зажим первого элемента установить зажим второго элемен-
та. При правильном соединении зажимы преобразуются в квадраты 
голубого цвета. Если соединения не произошло, НЛКМ на элементе и, 
не отпуская клавишу, перетаскиваем элемент в нужное место; 

- НЛКМ Capacitor в Lumped Element, чтобы вызвать модели ем-
костей в окне, расположенном под деревом элементов; 

- НЛКМ на модели емкости Cap и, не отпуская клавишу, пере-
таскиваем емкость на поле схемы; 

- помещаем курсор в нижний зажим емкости С1, НЛКМ и, не от-
пуская клавишу, проводим линию соединения с нижними зажимами С2 
и С3 и НЛКМ еще раз на последнем зажиме; 

- выбираем команду Schematic>Add Port, устанавливаем курсор 
на входе схемы, т.е. на зажиме первой индуктивности и подсоединяем 
порт к правой индуктивности, предварительно НПКМ для разворота 
порта на 180°. Более простой способ заключается в вызове порта с па-
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нели инструментов. Для этого нужно НЛКМ на кнопке Port и устано-
вить порт в схему; 

- выбираем команду Schematic>Add Ground, устанавливаем кур-
сор в схему на зажиме емкости С1 и НЛКМ; земля будет подключена к 
схеме. 

1.5. Редактируем элементы на схеме: 
- дважды НЛКМ на индуктивности L1 в окне схемы; откроется 

диалоговое окно; 
- в окно индуктивности вводим величину 1,5 и НЛКМ ОК, и т.д. 

Более быстрый путь редактирования - НЛКМ на параметрах элемента. 
Подводим крестик к редактируемой строке и дважды НЛКМ. Появится 
окно редактирования, в которое нужно ввести необходимые изменения. 

1.6. Определяем частоту моделирования:  
- дважды НЛКМ на папке Project Options в дереве проекта; от-

кроется диалоговое окно (рис. 6); 
 

 
Рис. 6. Диалоговое окно для установки частоты моделирования 

 
- НЛКМ Frequency Values; 
- заполняем окна Start - 4, Stop - 6, Step – 0,1 и НЛКМ Apply; час-

тотный диапазон по шагам отразится в окне Current Range; НЛКМ ОК. 
1.7. Создаем график:  
- НЛКМ Graphs в дереве проекта и выбираем Add Graphs для вы-

зова диалогового окна; 
- определяем s21 и s11 в Graph Name;  



 13 

- выбираем Rectangular для Graph Type и НЛКМ OK; график поя-
вится в окне рабочего пространства, одновременно папка Graph поя-
вится в дереве проекта. 

1.8. Добавляем измерения: 
- НЛКМ s21 и s11 в дереве проекта и выбираем Add Measurement; 

откроется диалоговое окно Add Measurement; 
- выбираем Port Parameters в окне Meas;  
- выбираем в качестве измеряемой характеристики s в окне 

Measurement;  
- в правом окне Date Source Name выбираем имя фильтра, а в ок-

нах To port index и From port index устанавливаем по 1;  
- выбираем Mag в Complex Modifier;  
- выбираем dB в Result Typ и затем НЛКМ Add; 
- изменяем значение в To port index на 2 и НЛКМ Add, чтобы до-

бавить второе измерение; 
- НЛКМ Close; в дереве проектов появятся папки: DB (|S [1,1] |) 

и DB (|S [2,1] |). 
1.9. Анализируем схему: выбираем команду Simulate>Analyze 

или НЛКМ на кнопке Analyze на панели инструментов для проведения 
моделирования (рис. 7). 

 

 
Рис. 7. Результаты моделирования 

 
2. Подстройка параметров элементов схемы 

 
Алгоритм подстройки параметров элементов состоит в следую-

щем: 
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- НЛКМ на кнопке Tune Tool, расположенной на панели инстру-
ментов;  

- курсором в виде отвертки указываем те параметры элементов 
схемы, которые будут меняться; 

- нажимаем на кнопку Tune и на рабочем поле появится окно с 
рычажками настройки; 

- с помощью рычагов настройки изменяем параметры элементов 
схемы. 

 
3. Построение и анализ активных цепей 

 
3.1. Создаем схему:  
- выбираем команду Project>Add Schematics>New Schematics; 
- называем схему определенным именем (например - TLA); на 

рабочем поле появится окно схемы и в папке Circuits Schematics в дере-
ве проекта появится папка новой схемы. 

3.2. Размещаем элементы в схеме (рис. 8). 
 

 
Рис. 8. Проектируемая схема 

 
3.3. Размещаем активный элемент: 
- во вкладке Proj выбираем папку Date Files; 
- НПКМ и выбираем вкладку Import Date Files; 
- указываем место, где находится файл описания транзистора, 

например - SXA-389 в виде четырехполюсника со встроенными цепями 
смещения; 

- вызываем  дерево элементов Elem; 
- выбираем папку Subcircuits; 
- НЛКМ на подсхеме транзистора и, не отпуская клавишу, пере-

таскиваем подсхему с описанием транзистора на рабочее поле схемы. 
3.4. Размещаем согласующие отрезки полосковой линии: 
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- выбираем Microstrip>Lines>MLIN, перетаскиваем в поле схемы; 
- устанавливаем указанные на рис. 8 длину и ширину отрезков 

полосковой линии. 
3.5. Размещаем конденсаторы и порты на схеме: 
- НЛКМ Capacitor в Lumped Element, чтобы вызвать модели ем-

костей в окне, расположенном под деревом элементов; 
- НЛКМ на модели емкости Cap и, не отпуская клавишу, пере-

таскиваем емкость на поле схемы; 
- выбираем команду Schematic>Add Port, устанавливаем порт в 

схему; 
- устанавливаем заземление в схему. 
3.6. Указываем свойство подложки схемы и тип линии: 
- в дереве элементов НЛКМ на Substrate; 
- выбираем MSAB; 
- НЛКМ на MSAB и, не отпуская клавишу, перетаскиваем под-

ложку с линией на поле схемы; 
- дважды НЛКМ на подложке и заполняем таблицу свойств: h = 

=0,8мм, er = 4,2, tgd = 0,02, t = 50 мкм. 
В итоге схема в МО принимает следующий вид (рис. 9). 

 

 
Рис. 9. Схема усилителя в МО 

 
3.7. Анализируем схему: 
- дважды НЛКМ на папке Project Options в дереве проекта;  
- НЛКМ по Frequency Values; 
- заполняем окна Start (1,4 ГГЦ), Stop (2,0 ГГЦ), Step (0,05 ГГЦ); 
-  НЛКМ Apply; 
- НЛКМ Graphs в дереве проекта и выбираем Add Graphs для вы-

зова диалогового окна; 
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- определяем VSWR (КСВ напряжения) в Graph Name;  
- выбираем Rectangular для Graph Type и НЛКМ OK; график поя-

вится в окне рабочего пространства, одновременно папка VSWR  поя-
вится в дереве проекта; 

- добавим измерения в графики VSWR: НЛКМ VSWR в дереве 
проекта и выбираем Add Measurement; откроется диалоговое окно Add 
Measurement; 

- выбираем Linear в окне Meas;  
- выбираем в качестве измеряемой характеристики VSWR в окне 

Measurement;  
- в правом окне Date Source Name выбираем имя TLA, а в окне 

Port index – 1;  
- аналогично строим график КСВ на выходе (Port index – 2); 
- создаем отдельный график для коэффициента усиления: выби-

раем Linear Gain в окне Meas;  
- выбираем в качестве измеряемой характеристики GA в окне 

Measurement;  
- в правом окне Date Source Name выбираем имя TLA; 
- запускаем проект на моделирование; 
- при необходимости настраиваем график, для чего НПКМ на 

графике и выбираем вкладку Properties; 
- в открывшемся диалоговом окне Rectangular Plot Properties 

НЛКМ по Limits и устанавливаем пределы изменения частоты по оси Х 
и пределы изменения параметров по оси Y, НЛКМ по Divisions и опре-
деляем масштаб графика. 

 
4. Оптимизация параметров 
 
Оптимизация параметров производится в следующей последова-

тельности. 
4.1. Определяем цели оптимизации: 
- переходим в дерево проектов; 
- НПКМ на Optimizer Goals и выбираем Add Opt Goal; 
- в появившемся диалоговом окне Optimization Goal во вкладке 

Measurement выбираем параметр оптимизации, например  - TLA:GA; 
- в окне Type Goal выбираем тип оптимизации Meas>Goal; 
- убираем флажок из окна Max из области Range и вводим 1.8 в 

окно Stop, убираем флажок из окна Min  и вводим 1.6 в окно Start, оп-
ределяя диапазон частот, в котором будет оптимизироваться коэффи-
циент усиления;  
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- устанавливаем цель оптимизации 40 в окне Goal и НЛКМ ОК; 
- определяем параметры схемы, которые будут меняться в ре-

зультате оптимизации: НЛКМ на вкладке Var и в нижнем левом окне 
появится список переменных параметров схемы;  

- в качестве параметров оптимизации выберем длины отрезков 
МПЛ TL1и TL2 и величины емкостей C1 и C2, щелкнув по кнопке О 
слева от выбранного параметра; черный цвет буквы должен измениться 
на красный. 

4.2. Приступаем к процедуре оптимизации:  
- выбираем Simulate>Optimize; 
- в диалоговом окне в правой вкладке Optimization Methods выби-

раем метод оптимизации (Gradient Optimization) и устанавливаем 1000 
в окне Maximum Iterations;  

- НЛКМ Start - начнется оптимизация схемы, при этом откроется 
диалоговое окно оптимизации; 

- когда моделирование завершится, НЛКМ Close и закройте диа-
логовое окно. 

Результаты оптимизации отразятся на соответствующем графике. 
 

ЗАДАНИЕ НА ИССЛЕДОВАНИЕ 
 

1.  В соответствии с таблицей задания выберите тип анализируе-
мой цепи. 
 

Таблица заданий 
N 

вар. 
Тип цепи f 0,7 или 

f ц, ГГц 

N 
вар. 

Тип цепи f 0,7 или 

f ц, ГГц 

1 ФНЧ 4,0 11 ФВЧ 4,6 
2 ФВЧ 4,0 12 Пол.фильтр 4,6 
3 Пол.фильтр 4,0 13 ФНЧ 4,8 
4 ФНЧ 4,2 14 ФВЧ 4,8 
5 ФВЧ 4,2 15 Пол.фильтр 4,8 
6 Пол.фильтр 4,2 16 ФНЧ 5,0 
7 ФНЧ 4,4 17 ФВЧ 5,0 
8 ФВЧ 4,4 18 Пол.фильтр 5,0 
9 Пол.фильтр 4,4 19 ФНЧ 5,2 

10 ФНЧ 4,6 20 ФВЧ 5,2 
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2. Постройте выбранную цепь на основе элементов с сосредото-
ченными параметрами (пример на рис. 3). 

3. Проведите моделирование работы цепи: определите парамет-
ры S11 и S21. 

4. Используя режим Tune, подстройте полученную цепь в соот-
ветствии с требованием задания. 

5. Запишите полученные значения номиналов элементов схемы и 
зарисуйте полученные графики, которые будут использоваться во вто-
рой работе. 

6. Используя режим Tune, измените значение f 0,7 или f ц на 10 

% относительно исходного задания. 
7. Выполните все описанные в пункте 3 этапы анализа линейного 

усилителя. 
8. Проведите оптимизацию параметров полученного усилителя 

по примеру пункта 4. 
 

ВОПРОСЫ ДЛЯ САМОСТОЯТЕЛЬНОЙ ПОДГОТОВКИ 
 

1.  Основное назначение и возможности среды Microwave Office. 
2. Основные особенности построения и анализа элементов с со-

средоточенными параметрами в среде Microwave Office. 
3. Виды и назначения типовых полосковых структур среды 

Microwave Office. 
4. Основные особенности построения высокочастотного усили-

теля мощности. 
5. Задачи и способы согласования активного элемента в усилите-

ле. 
6. Способы и возможности подстройки параметров элементов 

схемы. 
7. Способы и возможности оптимизации схемы в среде 

Microwave Office. 
 
 

Лабораторная работа № 2 
 
ПОСТРОЕНИЕ И АНАЛИЗ ЛИНЕЙНЫХ ВЧ ЦЕПЕЙ  

С РАСПРЕДЕЛЕННЫМИ ПАРАМЕТРАМИ 
 

ЦЕЛЬ РАБОТЫ: построение и анализ ВЧ цепей с распределен-
ными параметрами на основе полосковых (микрополосковых) линий. 
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КРАТКИЕ СВЕДЕНИЯ 

 
1. Построение и анализ пассивных цепей, выполненных на 

полосковых элементах 
 
Рассмотрим построение и анализ пассивных цепей, выполнен-

ных на полосковых элементах на примере ФНЧ.  
Для проектирования фильтра в виде ЕМ-структуры в MO необ-

ходимо выполнить следующие действия: 
1.1. Создаем проект с определенным именем: File>New Project. 
1.2. Создаем ЕМ-структуру: Project>Add EM Structure> New EM 

Structure.  
1.3. Задаем размеры и параметры подложки:  
- в дереве проекта под EM Structure выбираем Enclosure;  
- в открывшемся окне есть несколько закладок, значения в кото-

рых определяют размеры и параметры материала. На первой закладке  
(Box Dimensions) устанавливаем размеры подложки по длине и ширине 
(Dimensions), а также размеры сетки (Division), на которую разбивается 
подложка при моделировании и анализе (рис. 10). Задавать очень мел-
кую сетку не следует, т.к. это хоть и увеличивает точность вычислений, 
однако значительно увеличивает время вычислений независимо от 
мощности компьютера. Уменьшать размеры сетки имеет смысл при 
окончательной доводке структуры, когда вся «черновая» работа уже 
выполнена и определены размеры структуры (в данном случае фильт-
ра);  

- на второй закладке (Dielectric Layers) определяются параметры 
непосредственно материала подложки (рис. 11). Поскольку разрабаты-
вается обычный полосковый фильтр на двустороннем материале, то 
необходимо задать параметры среды, находящиеся под полосковой 
линией и над ней. Над линией в данном случае находится воздух с от-
носительной диэлектрической проницаемостью 1 и потерями 0; 
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Рис. 10. Задание размеров подложки 

 

 
Рис. 11. Задание параметров диэлектрической подложки 

 
- необходимо указать непосредственно параметры подложки – 

материала, из которого будет изготовлен фильтр – это второй, нижний 
слой структуры. Нажав кнопку Add, можно выбрать необходимый ма-
териал из предлагаемого списка, либо, если известны параметры имею-
щегося материала, просто заполнить вручную соответствующие графы 
(Thickness – толщина, Er – диэлектрическая проницаемость, Loss Tan-
gent -  тангенс диэлектрических потерь); 

- на третьей закладке (Boundaries) показывается распределение 
слоёв в структуре. В нижней части этого раздела имеются две графы – 
Top Boundary и Bottom Boundary – это те среды, верхняя и нижняя со-
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ответственно, в которые заключена структура. Значения можно оста-
вить по умолчанию – Perfect Conductor.  

В окне ЕМ-структуры на подготовленной подложке нужно соз-
дать выбранную топологию фильтра. Формы могут импортироваться из 
файлов AutoCAD, DXF, GDSII, Sonet GEO. 

1.4. Построим структуру с помощью редактора МО: 
- выбираем Draw>Add Rect Conductor для добавления прямо-

угольного проводника; 
- в окне EM-структуры располагаем проводник и форматируем 

его до нужных размеров; 
- используя данные команды, рисуем выбранную топологию 

(рис.12).  
 

 
Рис. 12. Вид ФНЧ в полосковом исполнении 

 
Определить ширину полосок, из которых будет создаваться то-

пология, учитывая их волновые сопротивления можно с помощью вло-
женной команды МО: Windows>TxLine. 

1.6. При необходимости заземления участка фильтра используем 
перемычку к низу металлического корпуса: Draw>Add Via. 

1.7. Для просмотра двухмерного и трехмерного вида структуры 
используем соответственно команды: View>2D View и View>3D View. 
Для вращения трехмерной структуры: НЛКМ и вращение. 

1.8. Добавляем порты к полученной структуре: 
- НЛКМ на крайнем проводнике в структуре ЕМ; 
- выбираем Draw>Add Internal Port для добавления внутреннего 

порта или Draw>Add Edge Port для добавления внешнего порта (порта 
на краю платы); 
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- перемещаем курсор к левому краю проводника, пока не появит-
ся квадратик, и НЛКМ для размещения порта;  

- в случае внешнего порта для вычитания (разгерметизации) 
электрической линии из результата моделирования референсные плоско-
сти для порта должны быть сдвинуты от края платы. Для этого НПКМ в 
окне ЕМ структуры, и выберите View Area. Протяните курсор вокруг выбран-
ного порта и маленького проводника. НЛКМ на порту. Сдвигайте курсор к 
краю порта, пока не покажется двойная стрелка. НЛКМ и удерживайте кла-
вишу «мыши», чтобы увидеть dx и dy. Удерживайте клавишу, протащите 
курсор вправо, пока dx не покажет выбранную величину; 

- добавляем второй порт. 
1.9. По аналогии с первой работой (пп. 1.6-1.9) определяем час-

тоту моделирования, создаем график, добавляем измерения, анализиру-
ем схему. 

 
2. Экспорт и импорт топологий и схем 
 
В качестве примера рассмотрим экспорт и импорт полученной 

структуры ФНЧ. 
2.1. Для экспорта ЕМ-структуры: 
- переходим Project>EM Structures; 
-   НЛКМ на требуемой структуре и выбираем команду Export EM 

Structures. 
2.2. Для импорта ЕМ-структуры: 
- переходим Project>EM Structures; 
-   НЛКМ на EM Structures и выбираем команду Import EM Struc-

tures. 
Для доступа к указанной структуре необходимо открыть вкладку 

Elem и папку Subcircuits, где находится одноименная структура в виде 
подсхемы.  Кроме того, все созданные в текущем проекте структуры и 
схемы автоматически доступны как подсхемы в папке Subcircuits. 

 
3. Построение цепей с помощью стандартной библиотеки   

полосковых элементов 
 
Рассмотренная в п.1 методика построения цепей на полосковых 

элементах позволяет проектировать практически любые топологии, 
однако сильно ограничена в возможности оперативной подстройки эле-
ментов и требует при анализе значительных вычислительных затрат. 
Другим способом построения полосковых цепей, лишенным указанных 



 23 

недостатков, является использование стандартной библиотеки полос-
ковых элементов. Рассмотрим построение того же ФНЧ. 

3.1. Размещаем полосковые линии: 
- выбираем Elem>Microstrip>Lines>MLIN, перетаскиваем в поле 

схемы; 
- устанавливаем выбранные длину и ширину отрезков полоско-

вой линии. 
3.2. Установленные отрезки соединяем между собой: выбираем 

Microstrip>Junctions>MSTEPX$, перетаскиваем в поле схемы и соеди-
няем отрезки полосковой линии. 

3.3. Аналогично п.1.4 первой работы устанавливаем в схему пор-
ты. 

3.4. Соединяем все фаски элементов топологических ячеек вместе: 
- выбираем Schematic>View Layout, схема появится в топологиче-

ском окне; 
- выбираем Edit>Snap Together. 
3.5. Аналогично п.3.6 первой работы указываем свойство под-

ложки схемы и тип линии. 
В итоге схема в МО принимает следующий вид (рис. 13). 
 

 
Рис. 13. Схема ФНЧ в полосковом исполнении 

 
ЗАДАНИЕ НА ИССЛЕДОВАНИЕ 

 
1. Выберите тип диэлектрической подложки. 
2. На основе полученных в первой работе номиналов емкостей и 

индуктивностей выбранной цепи рассчитайте соответствующую топо-
логию на полосковых элементах.   
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3. Проведите моделирование работы цепи: определите парамет-
ры S11 и S21. 

4. Изменяя геометрические размеры реактивных элементов цепи, 
добейтесь соответствия параметров цепи исходному заданию (см. таб-
лицу заданий). 

5. Экспортируйте полученную топологию в новый проект и за-
ново проведите моделирование работы цепи. 

6. По полученной топологии постройте аналогичную цепь на ос-
нове стандартной библиотеки полосковых элементов. Промоделируйте 
ее работу. 

7. Используя режим Tune, подстройте полученную цепь в соот-
ветствии с требованием задания. 

8. Используя режим Tune, измените значение f 0,7 или f ц на 10 

% относительно исходного задания. 
9. Сделайте выводы о различиях в приемах построения и анализа 

рассмотренных методик работы со схемами на полосковых элементах.  
10. Сделайте выводы о различиях в параметрах цепи, реализо-

ванной на элементах L и С  (первая работа) и на полосках (коэффици-
ент отражения, равномерность в полосе пропускания, скорость спада). 
 

ВОПРОСЫ ДЛЯ САМОСТОЯТЕЛЬНОЙ ПОДГОТОВКИ 
 
1. Основные особенности построения и анализа элементов с рас-

пределенными параметрами в среде Microwave Office. 
2. Области применения и основные особенности полосковых и 

микрополосковых линий. 
3. Влияние топологии полосковой структуры на ее частотные 

свойства. 
4. Способы построения ФНЧ, ФВЧ и полосовых фильтров на ос-

нове полосковых структур. 
5. Выбор и влияние параметров подложки на характеристики по-

лосковых элементов схемы. 
6. Возможности автоматического проектирования фильтров в 

МО. 
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